The broken ROLI dashboard


ROLI Dashboard is used to control certain aspects of ROLI instruments such as the Seaboard and Lightpad. In particular, it can be used to change the Lightpad’s mode, going from the drum pad to the RISE controller. Unfortunately, sometimes, apparently more and more often, the Dashboard won’t work at all, showing the following error.

Oh no! It looks like the ROLI Hardware Driver isn’t running.

This is even worse. Start the ROLI Studio Player, either standalone or as a plugin, and you’ll see it cannot configure the Lightpad to control studio parameters.

This problem often appears after ROLI Connect performed an update. During the update process, the ROLI Hardware Driver is uninstalled and, for some unknown reason, not reinstalled properly. This post shows how this can be fixed. I started to have this issue after upgrading to Windows 11, but my friend with Windows 10 also experienced the problem while things were working fine before.

This post shows how I fixed this issue on three different systems so far. This may not be a universal solution. Other problems can happen with ROLI software, with any brand of software in fact, and I cannot be sure all readers will face the same issue. It is thus important to understand what you are doing. Do not just apply this blindly as a recipe.

Is the ROLI Hardware still there?

First step is to verify that ROLI Hardware Driver is still present as a Windows service. For this, press the Windows key to get the Start menu and type Services. Then in the list of services, search for ROLI Hardware driver. You may (or may not) find the service, as shown on the following image.

Windows services, showing ROLI Hardware driver is there

If the service is there, try to right-click its name and select Start. If the service doesn’t start, you unfortunately got a new bug that is not covered by this post. If the service is not there, you are at the right place and can try to follow the instructions below. I found no complete solution for this problem and had to do research to come up with something that fully solves the issue… until the next update.

Note however that given the weirdness of the issue, it could well happen that following instructions won’t work or won’t apply. You may then have to contact ROLI’s technical support, and hope for the best.

Fixing the ROLI Hardware driver

First thing is to make sure ROLI Hardware driver runs. First verify that ROLI Connect is still working. If it doesn’t work, reinstall it. The ROLI Dashboard should also « work », which means it starts without another error than the one above. In the Services window, you cannot find ROLI Hardware driver. First step is then to reinstall the service, as follows.

  1. Press the Windows key and search for the command prompt.
  2. Right click on the Command prompt text and select Run as administrator. You will have to approve the request to run the process as an administrator.
  3. Type cd « \Program Files\ROLI\ROLI Hardware Driver » and press Enter. If the command fails, you have a different issue. First try to uninstall ROLI Dashboard and ROLI Connect, then reinstall ROLI Connect, and come back at this.
  4. Type svc and press Enter. This command will only work if you run as an administrator, otherwise you’ll get an error message.
  5. Press i and Enter, to install a new service.
  6. As a service name, enter ROLI Hardware driver.
  7. As display name, also enter ROLI Hardware driver.
  8. When asked if the service can interact with desktop, press n for No and Enter.
  9. When asked for the start type, enter a for automatic, and press Enter.
  10. Leave error control as the default, i by just pressing Enter.
  11. For the binary path, enter exactly what follows: "\Program Files\ROLI\ROLI Hardware Driver\srvstart.exe" "ROLI Hardware Driver" -c "\Program Files\ROLI\ROLI Hardware Driver\srvstart_rhd.ini"
  12. svc asks for confirmation about the binary path it finds suspect. Just responde y for yes and press Enter.
  13. Press y and Enter when asked if the service must be started as the LocalSystem account.
  14. Press n and Enter when asked if service has dependencies.
  15. When asked if you are sure you want to install the service, press y and Enter.
  16. When asked for a new action, press x and Enter to exit.
  17. Type exit and press Enter to close the command prompt.

After all these steps, the ROLI Hardware driver service should be present in the list of services, when you press Windows key, and search for Services. Right-click on the ROLI Hardware driver and select Start. The service should start after a few seconds.

If the driver runs correctly, ROLI Dashboard will show your devices or, at worst, a screen similar to the following asking you to connect a device.

The MIDI driver

Making the Hardware Driver work is just part of the solution. After you reinstall the driver as a service, you may notice that the ROLI Dashboard only works partially. As soon as you start using your ROLI device with Studio Player or your DAW, you will quickly notice that Dashboard stops working. This is because access to the ROLI device is exclusive to one process. If you want to switch mode of your Lightpad, you will most likely need to unplug it, replug it, and try again, until Dashboard gets control of it, then you’ll have to unplug and replug until your DAW or Studio Player gets control, etc. This can be solved as follows!

First press the Windows key and search for program. Go to add or remove programs and search for ROLI.

If you don’t see roliMIDI64, you need to install that manually; this will fully solve the ROLI Dashboard issue.

For this, press Windows key + E to start Explorer and go to C:\Program Files\ROLI\ROLI Hardware Driver. Double-click on ROLIMultiClientMIDI64.msi and let this install.

That’s it. Problem solved. Now your DAW, Studio Player and Dashboard can see your ROLI devices and access the ROLI-specific settings again.