Defective keys and erratic keyboard shortcuts

One of the first thing I attempted to do on the Mac was to turn on full zoom and enlarge mouse pointer. This can be done from the System Preferences (Apple menu), Universal Access icon. Zoom was set to No, so I changed it to Yes.

Image 5

As a side note, the Mouse and trackpad tab offers a neat way to enlarge the mouse pointer. This is one of the greatest Mac OS X feature.

Image 6

The Sight tab is giving the keyboard shortcut to zoom and unzoom, unfortunately in a quite cryptic and hard to remember way. Instead of putting key names such as Command, Option, Shift, etc., Apple decided to use icons that make no sense. This is a real pain for me, because I have trouble associating these images with keys. But after some time, I figured out that the key combination to zoom was Command (key marked with an apple just left to the space bar), Option (key just left to the Command key) and =. However, hitting that key combination just did nothing. I tried several times, without success. I also tried Command-Option-8 many times to make sure that zoom was effectively enabled.

Starting to suspect the key wasn’t responding physically, I started a Terminal and launched xev, an utility I know of from my UNIX/Linux background. xev listens to events and displays the name X receives when the event occurs. This is a way to figure out what is generated when a key is pressed, a mouse button is used, etc. Pressing on Command, Shift, =, and some other keys, had an effet. However, pressing on Option did… nothing.

Ok, maybe some misbehaved application was intercepting the Option keys. To iron this out, I wanted to boot this machine off an Ubuntu USB stick. The main idea to achieve that is to insert the stick and press Option at boot, just after hearing the chime. No matter how much times I tried this, it had no effect.

I finally tested with an external USB keyboard, but that was a PC keyboard, since I don’t have a spare Mac USB keyboard hanging around in my house. This is not ideal, because some keys are misplaced and quite confusing. In particular, to get the Command key on the PC keyboard, I have to press the Windows key. Option is mapped to Alt. This knowledge in mind, acquired from my experience with a Hackintosh, I tried Windows-Alt-= and got the zoom! Ok, so Mac OS X is processing Option key, but the builtin keyboard is not capable of producing it.

The only way I can zoom in with just the built in keyboard is by hitting Shift and scrolling with two fingers on the trackpad.

Note that I successfully got the EFI boot menu by turning on the Mac while hooked to an external keyboard and hitting Alt key after the chime. However, I had to repeat the manipulation five or six times until it succeeded. That remembered me of the memorable trouble I got while trying to jailbreak my iPod after upgrade to iOS 4; entering DFU was hard and no instruction given on the Internet was working. I had to use completely different timings than one given on web sites! Seems Apple likes these hard to guess procedures, to be alone able to debug things, but that excludes cases of old out-of-warranty devices!

But that’s not the end of the story. Quick enough, I wanted to open up the main menu bar without using the mouse. I know there is a way: CTRL-F1 to enable universal keyboard access, then CTRL-F2. This again comes from my Hackintosh experience. So I tried… with no luck.

After a little trial and error, I found out that F1 through F10 don’t produce F1 through F10 but rather special behavior, like adjusting LCD brightness, volume, keyboard backlight, etc. Correct, no problem with that, if I can get F1 through F10 another way. From previous intuitions with laptops, I figured out that fn key combined with F2 would do the trick, so Ctrl-Fn-F2 would open up the menu bar. Well no! Fn key seems defective and not responding as well, same for Escape!

Any Google search about this got me absolutely no positive results. It seems I would have to replace the keyboard, which would involve purchasing a completely new chassis, disassembling the MacBook Pro and reassembling it in the new chassis. This is just a non-sense and too costly job. I’m not ready, nor technically, nor mentally, to engage into such an operation. I could do it on a desktop PC if I had to, because I know how they are put together, but I have no knowledge, no mental model, about how the components of MacBook Pro are put together.

Lack of the fn key also prevents the production of the Home, End, Page Up and Page Down keys by combining Fn with the arrow keys. I will probably discover other impossible to obtain keys. For now, it is far better to hook up an external USB keyboard to this machine, especially to be in front on a larger external monitor when using it.

Even with an external USB keyboard, some shortcuts don’t always respond. For example, Ctrl-F2 doesn’t always open the menu. It seems that when the machine is busy, it just happily skips the interpretation of the shortcut! Sometimes, the machine produces an annoying beep when I hit Ctrl-F2 instead of popping up the menu. Combined with other issues, this sometimes got me mad, almost drove me crazy!

The use of a PC keyboard complicates things. To get a /, I have to combine right Alt with é key. Same right alt acrobatics are needed for ~, {, }, [, ], |, etc. The ù is obtained by the key just left to the number 1 while on the MacBook Pro keyboard, it is left to the Z key.

Some keyboard shortcuts I am used to just don’t work: Windows-Tab instead of Alt-Tab, Windows-L instead of Ctrl-L, etc. The Home key, rather than going at the beginning of the current line, jumps at the beginning of the file, forcing me to return at the point I was while editing. This happens for documents in text processors as well as text edited on web interface such as WordPress. This is minor compared to problems caused by defective keys or shortcuts not always responding, but this adds up to make a really bad and extremely frustrating user experience.






Étiquettes :